Creating An Email To SMS/MMS API Outlook Template

If you are using Outlook 2000/2003 to compose the emails for sending SMS or MMS messages using our API's then you can significantly speed up the process by creating a template for the email message and assigning it to a toolbar icon. The whole process takes less than ten minutes to set-up and will save you a lot of time and effort.

Creating The Template

Turn Off Word As Your Email Editor

If you have Word set as your email editor you must turn it off (temporarily) before continuing. To do this follow these steps:

  1. From the Outlook main menu select Tools->Options
  2. Then select the "Mail Format" tab
  3. Un-check the "Use Microsoft Word to edit email messages" option
  4. Then click OK

Create The Template Email(s)

You can either follow the manual instructions below, or use the prepared templates instructions (recommended).

Prepared Templates

  1. Download this template file (ZIP)
  2. Extract the contents to your templates directory (usually C:\Documents and Settings\<login name><\Application Data\Microsoft\Templates\)
  3. For each template you want to use (called format1.oft to format4.oft), double click the extracted file and enter your Username and PIN in the indicated place.
  4. Overwrite the previous copy (select File->Save As.., change Save As Type to Outlook Template and press Save)

Manually Create The Templates

  1. Start a new message, just as you would normally (Select File->New->Mail Message from the Outlook main menu).
  2. Set the To: if so defined by the API. (e.g. <username>@itsarrived.net for format2)
  3. Set the Subject as defined by the API you are using (e.g. format2)
  4. Set the message body as defined by the API you are using (e.g. PIN=<PIN>... for format2)
  5. Select File->Save As... from the Outlook main menu
  6. Change the "Save As Type" to Outlook Template (*.oft)
  7. Enter a suitable file name (e.g. format2.oft)
  8. Press Save (it should save it to the default template directory for you which is something like C:\Documents and Settings\<login name><\Application Data\Microsoft\Templates\*.oft)
  9. Close the new message window now you've saved it. Say yes if it asks you save changes.

Turn On Word As Your Email Editor Again

If Word is your usual email editor you can turn it back on again now. To do so follow these steps:

  1. From the Outlook main menu select Tools->Options
  2. Then select the "Mail Format" tab
  3. Check the "Use Microsoft Word to edit email messages" option
  4. Then click OK

Using The Template

From The Menu

To use the template when creating a new email message is now very simple:

  1. From the Outlook main menu select Tools->Forms->Choose Form...
  2. From the Look In: drop-down select "User Templates in File System"
  3. Your template should now appear in the template list box (e.g. format2)
  4. Select your template and you can see it's display name and file name
  5. Then click Open
  6. A new mail message window will pop up populated with your template details.
  7. Modify the email as necessary (e.g. change the Message=... section)
  8. Press Send when you are done.

From A New Toolbar Button

You can make the whole process even simpler and more intuitive by creating your own custom toolbar button which opens a new message with the template from a single click.

  1. From the Outlook main menu select Tools->Customize... and select the Commands tab from the Customize dialog that pops up.
  2. From the Customize dialog, click and drag the Mail Message Command from the list, and drop it onto the main window toolbar where it will then add itself as a new icon.
  3. Right click on this new icon and select Edit Button Image... from the drop down menu.
  4. Edit the image how you want to make it uniquely identifiable in your toolbar. Perhaps erase it and draw a simple phone icon, for example.
  5. Click OK when you have finished editing it and you will see the icon updated in your toolbar.
  6. Right click your new icon again and select Assign Hyperlink->Open... from the drop down menu.
  7. A new dialog will pop up called "Edit Hyperlink: Open". Select using the "Existing File Or Web Page" option in the Link to: section then click the Browse for: File button on the right.
  8. Change the "File of type:" setting to All files (*.*) in the file browser that pops up.
  9. Now browse to the template directory where you saved the email template(s) (which will probably be something like C:\Documents and Settings\<login name><\Application Data\Microsoft\Templates).
  10. Select your template from the list and Click OK.
  11. Click OK again and then Close.
Now, whenever you click on your new toolbar icon you will have an almost complete message ready to simply enter your message and send!

Your session is about to expire

You will be logged out in seconds.

Do you want to stay signed in?

Yes, keep me signed in     No, Sign me out